Revit 2024 API |
Element..::..IsModifiable Property |
Element Class See Also |
Identifies if the element is modifiable.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2023
Syntax
C# |
---|
public bool IsModifiable { get; } |
Visual Basic |
---|
Public ReadOnly Property IsModifiable As Boolean Get |
Visual C++ |
---|
public: property bool IsModifiable { bool get (); } |
Remarks
This is not a permanent state. The value depends on the document state. For example, active edit modes can make IsModifiable false for many elements.