Loads the contents of this family document into another document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
Visual Basic |
---|
Public Function LoadFamily ( _
targetDocument As Document _
) As Family |
Return Value
Reference of the family in the target document.
Remarks
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentNullException |
Thrown when the input argument-"targetDocument"-is nullNothingnullptra null reference (Nothing in Visual Basic).
|
Autodesk.Revit.Exceptions..::..InvalidOperationException |
Thrown when the current document is not a family document,
or when the target document is modifiable (e.g. there is an uncommitted transaction) or doesn't support load of this kind of families (e.g. loading a model family to detail family is disallowed),
or when this family was found in the target document already and the conflict caused an automatic abort of the load operation,
or when a shared family in this family was found in the target document already
and the conflict caused an automatic abort of the load operation,
or this document is currently in a read-only state.
|
Autodesk.Revit.Exceptions..::..ForbiddenForDynamicUpdateException |
Thrown if this method is called during dynamic update. |
See Also