Represents electrical voltage type. An electrical voltage type define a range of voltages,
and circuits can be created between components with rated voltages that do not precisely match the voltage definition value.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class VoltageType : ElementType |
Visual Basic |
---|
Public Class VoltageType _ Inherits ElementType |
Visual C++ |
---|
public ref class VoltageType : public ElementType |
Remarks
Actual, minimum and maximum value of voltage type can retrieved through properties, but only can
be modified through SetVoltageValue method. All the unit of voltage properties in this class is volt.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..VoltageType
Autodesk.Revit.DB..::..Element
Autodesk.Revit.DB..::..ElementType
Autodesk.Revit.DB.Electrical..::..VoltageType