Exports a selection of views in DGN format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
Visual Basic |
---|
Public Function Export ( _
folder As String, _
name As String, _
views As ICollection(Of ElementId), _
options As DGNExportOptions _
) As Boolean |
Parameters
- folder
- Type: System..::..String
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: System..::..String
Either the name of a single file or a prefix for a set of files.
If empty, automatic naming will be used.
If nullNothingnullptra null reference (Nothing in Visual Basic), throw ArgumentException.
- views
- Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Selection of views to be exported. The set must contain at least one valid view.
- options
- Type: Autodesk.Revit.DB..::..DGNExportOptions
Various options applicable to the DGN format.
If nullNothingnullptra null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
True if successful, otherwise False.
Remarks
Examples
CopyC#
public bool ExportDGN(Document document, View view)
{
bool exported = false;
IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
if (setupNames.Count > 0)
{
DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);
if (view.CanBePrinted == true)
{
ICollection<ElementId> views = new List<ElementId>();
views.Add(view.Id);
exported = document.Export(Path.GetDirectoryName(document.PathName),
Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
}
}
return exported;
}
CopyVB.NET
Public Function ExportDGN(document As Document, view As View) As Boolean
Dim exported As Boolean = False
Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
If setupNames.Count > 0 Then
Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))
If view.CanBePrinted = True Then
Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
views.Add(view.Id)
exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
End If
End If
Return exported
End Function
Exceptions
See Also