Obtains the IFC class name associated to a given category id for the current export.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2013
Syntax
Visual Basic |
---|
Public Shared Function GetIFCClassNameByCategory ( _
catId As ElementId, _
exporterIFC As ExporterIFC _
) As String |
Visual C++ |
---|
public:
static String^ GetIFCClassNameByCategory(
ElementId^ catId,
ExporterIFC^ exporterIFC
) |
Return Value
The IFC class name. This is an empty string if the element should not be exported because it is not
found in the mapping file.
Remarks
Exceptions
See Also