Revit 2024 API |
Element..::..Parameter Property (Definition) |
Element Class See Also |
Retrieves a parameter from the element based on its definition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public Parameter this[ Definition definition ] { get; } |
Visual Basic |
---|
Public ReadOnly Property Parameter ( _ definition As Definition _ ) As Parameter Get |
Visual C++ |
---|
public: property Parameter^ Parameter[Definition^ definition] { Parameter^ get (Definition^ definition); } |
Parameters
- definition
- Type: Autodesk.Revit.DB..::..Definition
The internal or external definition of the parameter.
Remarks
Parameters are a generic form of data storage within elements. The parameters are visible
through the Autodesk Revit user interface in the Element Properties dialog. An element can only
have one instance of a parameter with a specific definition. By using this method you can retrieve that parameter based on definition.