IsValidShape Method (IList(GeometryObject))
Validates shape to be stored in a DirectShapeType.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public bool IsValidShape(
	IList<GeometryObject> shape
)
Visual Basic
Public Function IsValidShape ( _
	shape As IList(Of GeometryObject) _
) As Boolean
Visual C++
public:
bool IsValidShape(
	IList<GeometryObject^>^ shape
)

Parameters

shape
Type: System.Collections.Generic..::..IList<(Of <(<'GeometryObject>)>)>
Shape to be validated represented as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.

Return Value

True if the supplied shape passes the validation criteria.

Remarks

This function calls IsValidShape(GeometryObject) to validate each object in the list.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was null

See Also