Autodesk.Revit.DB.Macros Namespace
 

Classes

  ClassDescription
Public classAddInIdAttribute
The custom AddInId attribute for Macros macros use only.
Public classApplicationEntryPoint
For Revit Macros use only.
Public classDocumentEntryPoint
For Revit Macros use only.
Public classMacro
An individual Autodesk Revit Macro which can be executed.
Public classMacroManager
Manager object for the Macro modules of the application.
Public classMacroManagerIterator
An iterator to a MacroManager.
Public classMacroModule
A container for individual macros. As it relates to the macros editor, one MacroModule represents a project that can be loaded and edited from within the editor.
Public classMacroModuleIterator
An iterator to the Macros in a MacroModule.
Public classModuleSettings
The module settings.
Public classVendorIdAttribute
The custom VendorId attribute for Macros macros use only.

Interfaces

  InterfaceDescription
Public interfaceIEntryPoint
The interface supporting Document and Application level entry point classes for macros.

Enumerations

  EnumerationDescription
Public enumerationApplicationMacroOptions
The application macro options.
Public enumerationDocumentMacroOptions
The document macro options.
Public enumerationMacroEnvironment
The Macro environments.
Public enumerationMacroLanguageType
The Macro language types.
Public enumerationMacroLevel
The Macro levels.
Public enumerationModuleStatus
The Macro module status.