Revit 2024 API |
Document..::..DocumentPrinted Event |
Document Class See Also |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2010
Syntax
C# |
---|
public event EventHandler<DocumentPrintedEventArgs> DocumentPrinted |
Visual Basic |
---|
Public Event DocumentPrinted As EventHandler(Of DocumentPrintedEventArgs) |
Visual C++ |
---|
public: event EventHandler<DocumentPrintedEventArgs^>^ DocumentPrinted { void add (EventHandler<DocumentPrintedEventArgs^>^ value); void remove (EventHandler<DocumentPrintedEventArgs^>^ value); } |
Remarks
This event is raised immediately after Revit has finished printing a view or ViewSet of the document. It is raised even when document printing failed or was cancelled (during DocumentPriting event).
Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.
Check the 'Status' field in event's argument to see whether the action itself was successful or not.
This event is not cancellable, for the process of printing has already been finished.
If the action was not successful, the document may not be modified and new transactions may not be started.
The following API functions are not available for the current document during this event:
- Close()()()() and similar overloads.
Exception InvalidOperationException will be thrown if any of the above methods is called during this event.