This class is used to attach steel fabrication information to various Revit elements.
Namespace: Autodesk.Revit.DB.Steel
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2019
Syntax
Remarks
Revit elements which can have fabrication information are:
- FamilyInstance (structural beams and columns).
- StructuralConnectionHandler elements associated to the connection.
- Specific steel connection elements (bolts, anchors, plates, etc). These connection elements will be of type element but with categories related to structural connections, for example:
- OST_StructConnectionWelds
- OST_StructConnectionHoles
- OST_StructConnectionModifiers
- OST_StructConnectionShearStuds
- OST_StructConnectionBolts
- OST_StructConnectionAnchors
- OST_StructConnectionPlates
- Some concrete elements (walls, floors, concrete beams, ...) when they are input elements to detailed steel connections.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Steel..::..SteelElementProperties
Autodesk.Revit.DB..::..APIObject
Autodesk.Revit.DB.Steel..::..SteelElementProperties