RemoveReferenceObject Method (String)
Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public void RemoveReferenceObject(
	string refName
)
Visual Basic
Public Sub RemoveReferenceObject ( _
	refName As String _
)
Visual C++
public:
void RemoveReferenceObject(
	String^ refName
)

Parameters

refName
Type: System..::..String
The name of the reference object(s) to be removed.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was null

See Also