Revit 2024 API |
FamilyInstance..::..AddCoping Method |
FamilyInstance Class See Also |
Adds a coping (cut) to a steel beam.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public bool AddCoping( FamilyInstance cutter ) |
Visual Basic |
---|
Public Function AddCoping ( _ cutter As FamilyInstance _ ) As Boolean |
Visual C++ |
---|
public: bool AddCoping( FamilyInstance^ cutter ) |
Parameters
- cutter
- Type: Autodesk.Revit.DB..::..FamilyInstance
A steel beam or column. May not be nullNothingnullptra null reference (Nothing in Visual Basic) or itself.
Remarks
This beam will be cut to fit another element, the cutter. The cut will include an offset
determined by the parameter STRUCTURAL_COPING_DISTANCE. The parameter affects all copings
on this element. This function corresponds to Tools -> Coping in Revit Structure.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when 'cutter' is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when 'cutter' refers to this instance. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when regeneration fails. |