Represents a line pattern definition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public class LinePattern : IDisposable |
Visual Basic |
---|
Public Class LinePattern _ Implements IDisposable |
Visual C++ |
---|
public ref class LinePattern : IDisposable |
Remarks
A line pattern is a pattern of dashes and dots used to control the way the lines of an object are drawn in Revit.
Line patterns are used in the definition of GraphicsStyle objects.
A line pattern is defined by a repeating sequence segments.
Each segment is a dash, a dot or a space.
A line pattern definition must contain an even number of segments, starting with a visible segment (a dash or a dot) and alternating between visible segments and spaces.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..LinePattern
Autodesk.Revit.DB..::..LinePattern