This class stores the diameter information from the RebarBarType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018.1
Syntax
C# |
---|
public class BarTypeDiameterOptions : IDisposable |
Visual Basic |
---|
Public Class BarTypeDiameterOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class BarTypeDiameterOptions : IDisposable |
Remarks
This class can be used to create a whole new set of diameter values for a RebarBarType.
It can be used when copying the diameter information as a bulk of data from a RebarBarType to another.
The new diameters can be set in the RebarBarType in the following way:
1. Create a BarTypeDiameterOptions object with the new diameters.
2. Set the new diameters in RebarBarType using [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)].
The method [!:Autodesk::Revit::DB::Structure::RebarBarType::SetBarTypeDiameters(Autodesk::Revit::DB::BarTypeDiameterOptions ^diametersOpt)]
is responsible for diameters validation.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..BarTypeDiameterOptions
Autodesk.Revit.DB..::..BarTypeDiameterOptions