Validates that the input curve is suitable for creating a direct shape type reference curve.
Bounded and unbounded lines are accepted.
Other bounded and unbounded curve types with natural bounds are accepted if they are not closed.
Unbounded periodic curves are not allowed.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2022
Syntax
C# |
---|
public static bool IsValidReferenceCurve(
Curve curve
) |
Visual Basic |
---|
Public Shared Function IsValidReferenceCurve ( _
curve As Curve _
) As Boolean |
Visual C++ |
---|
public:
static bool IsValidReferenceCurve(
Curve^ curve
) |
Return Value
True if the input curve point can be used to create a direct shape reference curve, false otherwise.
Exceptions
See Also