Create an instance of ProjectLocation in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2018
Syntax
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document where the new instance of ProjectLocation would be created in.
- siteLocationId
- Type: Autodesk.Revit.DB..::..ElementId
The ElementId of the SiteLocation to which the new ProjectLocation would be created.
- name
- Type: System..::..String
The name of the instance of ProjectLocation to be created.
Return Value
The newly created instance of ProjectLocation.
Remarks
Exceptions
Exception | Condition |
---|
Autodesk.Revit.Exceptions..::..ArgumentException |
document is not a project document.
-or-
The element siteLocationId does not exist in the document
-or-
name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
-or-
There is already a ProjectLocation with this name in the given SiteLocation.
|
Autodesk.Revit.Exceptions..::..ArgumentNullException |
A non-optional argument was null
|
Autodesk.Revit.Exceptions..::..ModificationForbiddenException |
The document is in failure mode: an operation has failed,
and Revit requires the user to either cancel the operation
or fix the problem (usually by deleting certain elements).
-or-
The document is being loaded, or is in the midst of another
sensitive process.
|
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException |
The document has no open transaction.
|
See Also