Revit 2024 API |
Document..::..SetDefaultElementTypeId Method |
Document Class See Also |
Sets the default element type id of the given DefaultElementType id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2015
Syntax
C# |
---|
public void SetDefaultElementTypeId( ElementTypeGroup defaultTypeId, ElementId typeId ) |
Visual Basic |
---|
Public Sub SetDefaultElementTypeId ( _ defaultTypeId As ElementTypeGroup, _ typeId As ElementId _ ) |
Visual C++ |
---|
public: void SetDefaultElementTypeId( ElementTypeGroup defaultTypeId, ElementId^ typeId ) |
Parameters
- defaultTypeId
- Type: Autodesk.Revit.DB..::..ElementTypeGroup
The default element type id.
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
The element type id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The element type id typeId is invalid for the give DefaultElementType id defaultTypeId. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |