Test the category id to make sure the category is allowed for a DirectShape or DirectShapeType.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2015
Syntax
Visual Basic |
---|
Public Shared Function IsValidCategoryId ( _
categoryId As ElementId, _
doc As Document _
) As Boolean |
Visual C++ |
---|
public:
static bool IsValidCategoryId(
ElementId^ categoryId,
Document^ doc
) |
Return Value
True if the category is allowed for a DirectShape or DirectShapeType, false if not.
Exceptions
See Also