Revit 2024 API |
ProjectPosition..::..Angle Property |
ProjectPosition Class See Also |
Angle from True North.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public double Angle { get; set; } |
Visual Basic |
---|
Public Property Angle As Double Get Set |
Visual C++ |
---|
public: property double Angle { double get (); void set (double value); } |
Remarks
This is the angle difference between project north and true north measured in
radians. It can have a value from -PI to PI.
If the parameter value is outside that range, it
will be shifted by 2*PI until it falls into range.