This class is used to control behavior of a DirectShapeType object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2021
Syntax
C# |
---|
public class DirectShapeTypeOptions : IDisposable |
Visual Basic |
---|
Public Class DirectShapeTypeOptions _ Implements IDisposable |
Visual C++ |
---|
public ref class DirectShapeTypeOptions : IDisposable |
Remarks
Use Enable/Disable functions to change the default behavior.
Use DirectShapeType.SetOptions to modify that object's behavior.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..DirectShapeTypeOptions
Autodesk.Revit.DB..::..DirectShapeTypeOptions