Revit 2024 API |
Autodesk.Revit.DB.Infrastructure Namespace |
Classes
Class | Description | |
---|---|---|
![]() | Alignment |
Represents an object which provides access to an underlying Revit alignment element.
|
![]() | AlignmentStationLabel |
Represents an object which provides access to a specialized Revit annotation element
used for labeling Alignment stations.
|
![]() | AlignmentStationLabelOptions |
Represents an object containing options for creating an AlignmentStationLabel.
|
![]() | AlignmentStationLabelSetOptions |
Represents an object containing options for creating a set of AlignmentStationLabel.
|
![]() | HorizontalCurveEndpoint |
Represents an endpoint (start or end) of a horizontal curve in Alignment geometry.
|
Enumerations
Enumeration | Description | |
---|---|---|
![]() | HorizontalCurveType |
Represents the curve types for the horizontal curves which define Alignment geometry.
|