Revit 2024 API |
IExternalServer..::..GetName Method |
IExternalServer Interface See Also |
Implement this method to return the name of the server.
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2013
Syntax
C# |
---|
string GetName() |
Visual Basic |
---|
Function GetName As String |
Visual C++ |
---|
String^ GetName() |
Return Value
Name of the server.
Remarks
Although a server is uniquely identified by its Id, the Name can identify it to the end user in UI when UI is appropriate for the corresponding external service.
Beside the requirement for the name to be a non-empty string, there are no other general restrictions imposed by the External Services Framework. However, the external service may have some specific rules in place for its servers.