Revit 2024 API |
ExportLineweightTable..::..Item Property |
ExportLineweightTable Class See Also |
A copy of the ExportLineweightInfo for the line weight's ExportLineweightKey.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2014
Syntax
C# |
---|
public ExportLineweightInfo this[ ExportLineweightKey lineweightKey ] { get; set; } |
Visual Basic |
---|
Public Default Property Item ( _ lineweightKey As ExportLineweightKey _ ) As ExportLineweightInfo Get Set |
Visual C++ |
---|
public: virtual property ExportLineweightInfo^ default[ExportLineweightKey^ lineweightKey] { ExportLineweightInfo^ get (ExportLineweightKey^ lineweightKey) sealed; void set (ExportLineweightKey^ lineweightKey, ExportLineweightInfo^ value) sealed; } |
Parameters
- lineweightKey
- Type: Autodesk.Revit.DB..::..ExportLineweightKey
Return Value
A copy of the ExportLineweightInfo.
Remarks
When getting this property, it returns a copy of the ExportLineweightInfo from the table. In order to
make changes to the ExportLineweightInfo and use those settings during export, set the modified
ExportLineweightInfo back into the table using the same key.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | When getting this property: An entry with the given key is not present in the table. |