Revit 2024 API |
Curve..::..MakeBound Method |
Curve Class See Also |
Changes the bounds of this curve to the specified values.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
public void MakeBound( double startParameter, double endParameter ) |
Visual Basic |
---|
Public Sub MakeBound ( _ startParameter As Double, _ endParameter As Double _ ) |
Visual C++ |
---|
public: void MakeBound( double startParameter, double endParameter ) |
Parameters
- startParameter
- Type: System..::..Double
The new parameter of the start point.
- endParameter
- Type: System..::..Double
The new parameter of the end point.
Remarks
If the curve is marked as read-only (because it was extracted directly from
a Revit element or collection/aggregation object), calling this method
causes the object to be changed to carry a disconnected copy of the original curve. The
modification will not affect the original curve or the object that supplied it.
Remarks
This method changes this curve to bound.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the specified values are infinite. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when endParameter is smaller than startParameter. |