IExtension Interface

IExtension Interface

An interface that supports the additional operation for Extension Status

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IExtension
Public Interface IExtension
public interface class IExtension
type IExtension = interface end

The IExtension type exposes the following members.

Properties
 NameDescription
Public propertyExtendedRetrieves or set the extension status at the end
Public propertyHasMiterRetrieves the miter status at the end
Public propertyIsMiterLockedRetrieves or set the miter locked status at the end.
Public propertySymbolicExtendedRetrieves or set the symbolic extension status at the end
Top
See Also