RebarShapeArcReferenceType Enumeration

RebarShapeArcReferenceType Enumeration

A Rebar Shape Definition constraint that is measured to a bend must take the bar diameter into account by specifying whether it measures to the exterior, centerline, or interior of the bend.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarShapeArcReferenceType
Public Enumeration RebarShapeArcReferenceType
public enum class RebarShapeArcReferenceType
type RebarShapeArcReferenceType
Members
Member nameValueDescription
Centerline0 Measure to the centerline of the bar.
External1 Measure to the exterior of the bend.
Internal-1 Measure to the interior of the bend.
See Also