Revit 2025.3 API
External |
The exception that is thrown when an issue in the Add-Ins resulted in an unexpected error.

SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsExternalApplicationException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsExternalApplicationException
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[SerializableAttribute] public class ExternalApplicationException : ApplicationException
<SerializableAttribute> Public Class ExternalApplicationException Inherits ApplicationException
[SerializableAttribute] public ref class ExternalApplicationException : public ApplicationException
[<SerializableAttribute>] type ExternalApplicationException = class inherit ApplicationException end
The ExternalApplicationException type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides ApplicationExceptionGetObjectData(SerializationInfo, StreamingContext)) |

Please contact your external application provider with the information about what led to this exception.
See Also