LocationPoint Class

LocationPoint Class

Provides location functionality for all elements that have a single insertion point.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLocation
      Autodesk.Revit.DBLocationPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LocationPoint : Location
Public Class LocationPoint
	Inherits Location
public ref class LocationPoint : public Location
type LocationPoint = 
    class
        inherit Location
    end

The LocationPoint type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyPointThe physical location of the element.
Public propertyRotationThe angle of rotation around the insertion point, in radians.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodMoveMove the element within the project by a specified vector.
(Inherited from Location)
Public methodRotateRotate the element within the project by a specified angle around a given axis.
(Inherited from Location)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The location point objects adds additional functionality to its base location object class. This includes setting the elements location to a specific point and retrieving its rotation around its insertion point. Inplace families do not have a single insertion point and therefore do not have meaningful LocationPoint data.
See Also