GenericForm.Name Property

GenericFormName Property

Get and Set the Name property

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public override string Name { set; }
Public Overrides WriteOnly Property Name As String
	Set
public:
virtual property String^ Name {
	void set (String^ value) override;
}
abstract Name : string with set
override Name : string with set

Property Value

String
Remarks
The method set is override to forbid the user to change the Name. When the user tries to call the method set for GenericForm object, an InvalidOperationException will be thrown.
See Also