Revit 2025.3 API
ToposolidCreate(Document, IListCurve |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Toposolid Create( Document document, IList<CurveLoop> profiles, IList<XYZ> points, ElementId topoTypeId, ElementId levelId )
Public Shared Function Create ( document As Document, profiles As IList(Of CurveLoop), points As IList(Of XYZ), topoTypeId As ElementId, levelId As ElementId ) As Toposolid
public: static Toposolid^ Create( Document^ document, IList<CurveLoop^>^ profiles, IList<XYZ^>^ points, ElementId^ topoTypeId, ElementId^ levelId )
static member Create : document : Document * profiles : IList<CurveLoop> * points : IList<XYZ> * topoTypeId : ElementId * levelId : ElementId -> Toposolid
Parameters
Return Value
ToposolidSee Also