Revit 2025.3 API
Numbering |
Returns all numbering sequences within this numbering schema.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IList<string> GetNumberingSequences()
Public Function GetNumberingSequences As IList(Of String)
public: IList<String^>^ GetNumberingSequences()
member GetNumberingSequences : unit -> IList<string>
Return Value
IListStringA collection of partition names of all numbering sequences currently present in this schema.

The collection may be empty if there are no elements yet in this schema.
One of the strings can be an empty string, which would indicate presence of the default partition into which elements automatically belong if left unassigned to any other partition
See Also