LinkLoadResultType Enumeration

LinkLoadResultType Enumeration

Enum listing the possible results after loading a linked model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum LinkLoadResultType
Public Enumeration LinkLoadResultType
public enum class LinkLoadResultType
type LinkLoadResultType
Members
Member nameValueDescription
CouldNotChangeViewReference12 The link previously had an invalid view reference and either no new view was provided or the input view was not usable for linking CAD files.
ExternalServerMissing9 The external add-in required to load this link model could not be found.
LinkExists10 Revit already has a link with the input location, so no new link can be created.
LinkLoaded1 The linked model loaded correctly.
LinkMayBeUpgraded8 Point cloud link loaded correctly but is obsolete and may be upgraded.
LinkNotFound2 The linked model could not be found.
LinkNotLoadedOtherError7 An unknown error occurred.
LinkNotOpenable3 An error occurred trying to read the linked model. It could happen if a wrong link type is trying to be loaded.
LinkOpenAsHost4 The linked model is already opened directly in Revit.
SameCentralModelAsHost6 Either the linked model and its host document are both locals of the same central model, or one is a local and the other is its central.
SameModelAsHost5 The linked model has the same path as the currently active document.
Uninitialized0 Revit has not tried to load the link, possibly because it is a nested link and its parent failed to load.
UsedExisting13 Revit already has a link with the input location, so the same link is been reused.
Remarks
For all values except LinkLoadResultType.LinkLoaded, the linked model is not loaded and no new link is created (if Revit was trying to create a link).
See Also