StructuralMaterialType Enumeration

StructuralMaterialType Enumeration

Represents the structural material type. This enum value is returned by Autodesk::Revit::DB::FamilyInstance::StructuralMaterialType.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum StructuralMaterialType
Public Enumeration StructuralMaterialType
public enum class StructuralMaterialType
type StructuralMaterialType
Members
Member nameValueDescription
Aluminum7 Structural material type is aluminum.
Concrete2 Structural material type is concrete.
Generic6 Structural material type is generic.
Other4 Structural material type is other.
PrecastConcrete5 Structural material type is precast concrete.
Steel1 Structural material type is steel.
Undefined0 Structural material type is undefined.
Wood3 Structural material type is wood.
See Also