SpatialElementGeometryResults Class

SpatialElementGeometryResults Class

The results of spatial element geometry calculation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSpatialElementGeometryResults

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SpatialElementGeometryResults : IDisposable
Public Class SpatialElementGeometryResults
	Implements IDisposable
public ref class SpatialElementGeometryResults : IDisposable
type SpatialElementGeometryResults = 
    class
        interface IDisposable
    end

The SpatialElementGeometryResults type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SpatialElementGeometryResults
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundaryFaceInfo Query the spatial element boundary face information with the given face.
Public methodGetGeometry The solid from the spatial element.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The subfaces of a SpatialElement at the base height and top height are not associated with floors, roofs, and ceilings at the same height.
See Also