ProfileFamilyUsage Enumeration

ProfileFamilyUsage Enumeration

An enumerated type listing all types of profile families.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ProfileFamilyUsage
Public Enumeration ProfileFamilyUsage
public enum class ProfileFamilyUsage
type ProfileFamilyUsage
Members
Member nameValueDescription
Any0 Any type of profile family.
ContinuousFooting10 Continuous Footing.
Fascia3 Fascia.
Gutter4 Gutter.
Mullion8 Mullion.
Railing6 Railing.
Reveal2 Reveal.
SlabEdge5 Slab edge.
SlabMetalDeck9 Slab Metal Deck.
StairNosing7 Stair Nosing.
StairRiser12 Stair Riser.
StairSupport13 Stair Support.
StairTread11 Stair Tread.
WallSweep1 Wall sweep.
See Also