Revit 2025.3 API
Evaluated |
The storage type describes the type that is used internally within the parameter to store its value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public StorageType StorageType { get; }
Public ReadOnly Property StorageType As StorageType Get
public: property StorageType StorageType { StorageType get (); }
member StorageType : StorageType with get
Property Value
StorageType
The property will return one of the following possibilities: String, Integer, Double or ElementId.
Based on the value of this property the correct access and set methods should be used to retrieve
and set the parameter's data value.
See Also