FamilySizeTable Class

FamilySizeTable Class

Contains size information for a family.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFamilySizeTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilySizeTable : IDisposable
Public Class FamilySizeTable
	Implements IDisposable
public ref class FamilySizeTable : IDisposable
type FamilySizeTable = 
    class
        interface IDisposable
    end

The FamilySizeTable type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyNumberOfColumns Number of columns in the table.
Public propertyNumberOfRows Number of rows in the table.
Top
Methods
 NameDescription
Public methodAsValueString Gets the table cell value as a string.
Public methodDisposeReleases all resources used by the FamilySizeTable
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetColumnHeader Gets a column of the table at at given index.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsValidColumnIndex Checks if the column index is valid.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also