ExternalResourceUtils Class

ExternalResourceUtils Class

A utility class containing functions related to external resource references.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalResourceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ExternalResourceUtils
Public NotInheritable Class ExternalResourceUtils
public ref class ExternalResourceUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalResourceUtils = class end

The ExternalResourceUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberGetAllExternalResourceReferences(Document) Gets the ids of all elements which refer to external resources.
Public methodStatic memberGetAllExternalResourceReferences(Document, ExternalResourceType) Gets the ids of all elements which refer to a specific type of external resource.
Top
Remarks
Elements which are external resource references refer to data outside of the base .rvt file. Examples include Revit links and the keynote table data.
See Also