IExternalServer.GetServiceId Method

IExternalServerGetServiceId Method

Implement this method to return the id of the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
ExternalServiceId GetServiceId()
Function GetServiceId As ExternalServiceId
ExternalServiceId^ GetServiceId()
abstract GetServiceId : unit -> ExternalServiceId 

Return Value

ExternalServiceId
The id of the service to which the server belongs.
Remarks
An external server belongs to only one external service. This method must return an Id that matches the Id of the corresponding service was registered with.
See Also