SpecUtils Class

SpecUtils Class

A utility class of functions related to specs. A spec describes a data type that parameters can hold.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSpecUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class SpecUtils
Public NotInheritable Class SpecUtils
public ref class SpecUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SpecUtils = class end

The SpecUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberGetAllSpecs Gets the identifiers of all specs.
Public methodStatic memberIsSpec Checks whether a ForgeTypeId identifies a spec.
Public methodStatic memberIsValidDataType Returns true if the given ForgeTypeId identifies a valid parameter data type.
Top
See Also