Revit 2025.3 API
Sun |
Use Revit's utilities to calculate the time zone for a given longitude and latitude.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static double CalculateTimeZone( double latitude, double longitude )
Public Shared Function CalculateTimeZone ( latitude As Double, longitude As Double ) As Double
public: static double CalculateTimeZone( double latitude, double longitude )
static member CalculateTimeZone : latitude : float * longitude : float -> float
Parameters
- latitude Double
- The latitude.
- longitude Double
- The longitude.
Return Value
DoubleThe time zone, in hours, ranging from +12 hours to -12 hours with 0 being GMT.

For some latitude and longitude boundary cases, the time zone calculated may not be correct.
The API offers the ability to adjust the time zone independent of Revit's calculations for situations
where this happens.
See Also