AreaVolumeSettings.ComputeVolumes Property

AreaVolumeSettingsComputeVolumes Property

True to enable volume computation. False to disable it.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool ComputeVolumes { get; set; }
Public Property ComputeVolumes As Boolean
	Get
	Set
public:
property bool ComputeVolumes {
	bool get ();
	void set (bool value);
}
member ComputeVolumes : bool with get, set

Property Value

Boolean
Remarks
When this setting is False, rooms and spaces will be treated as simple extrusions of their 2d boundaries. The volume parameter will report "not computed". When this setting is True, the geometry of rooms and spaces will be trimmed when it intersects elements such as ceilings, roofs, and floors.
See Also