ExternalDefinition.GUID Property

ExternalDefinitionGUID Property

Returns the GUID associated with the shared parameter definition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public virtual Guid GUID { get; }
Public Overridable ReadOnly Property GUID As Guid
	Get
public:
virtual property Guid GUID {
	Guid get ();
}
abstract GUID : Guid with get
override GUID : Guid with get

Property Value

Guid
Remarks
Each shared parameter when created is issued a unique identifier. This identifier can then be used at a later time to retrieve the parameter from the Element ensuring that the correct parameter is always retrieved.
See Also