StructuralWallUsage Enumeration

StructuralWallUsage Enumeration

Represents the structural usage of a wall.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum StructuralWallUsage
Public Enumeration StructuralWallUsage
public enum class StructuralWallUsage
type StructuralWallUsage
Members
Member nameValueDescription
Bearing1 Structural usage is bearing.
Combined3 Structural usage is combined.
NonBearing0 Structural usage is non-bearing.
Shear2 Structural usage is shear.
See Also