ElementType.GetSimilarTypes Method

ElementTypeGetSimilarTypes Method

Obtains a set of types that are similar to this type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ICollection<ElementId> GetSimilarTypes()
Public Function GetSimilarTypes As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ GetSimilarTypes()
member GetSimilarTypes : unit -> ICollection<ElementId> 

Return Value

ICollectionElementId
A set of element IDs of types that are similar to this type.
Remarks
Two types are similar if elements that have one type could be assigned the other type.
See Also