CurveLoopIterator Class

CurveLoopIterator Class

An iterator to a curve loop.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBCurveLoopIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurveLoopIterator : IEnumerator<Curve>
Public Class CurveLoopIterator
	Implements IEnumerator(Of Curve)
public ref class CurveLoopIterator : IEnumerator<Curve^>
type CurveLoopIterator = 
    class
        interface IEnumerator<Curve>
    end

The CurveLoopIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the CurveLoopIterator
Public methodMoveNext Increments the iterator to the next item.
Public methodReset Resets the iterator to the initial state.
Top
See Also