RoutingPreferenceRule Class

RoutingPreferenceRule Class

A class representing a rule set in MEP routing preferences.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBRoutingPreferenceRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RoutingPreferenceRule : IDisposable
Public Class RoutingPreferenceRule
	Implements IDisposable
public ref class RoutingPreferenceRule : IDisposable
type RoutingPreferenceRule = 
    class
        interface IDisposable
    end

The RoutingPreferenceRule type exposes the following members.

Constructors
 NameDescription
Public methodRoutingPreferenceRule Constructs a RoutingPreferenceRule containing a segment or fitting Id (MEPPartId) and description.
Top
Properties
 NameDescription
Public propertyDescription The description of the routing preference rule.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyMEPPartId The referenced MEPPart (segment or fitting) type in this rule. It may be InvalidElementId if no MEPPart will be allowed when the conditions satisfy the criteria in this rule.
Public propertyNumberOfCriteria Gets the number of routing criteria.
Public propertyRoutingPreferenceManager Gets the routing preference manager that owns this rule.
Top
Methods
 NameDescription
Public methodAddCriterion Adds a new routing criterion.
Public methodDisposeReleases all resources used by the RoutingPreferenceRule
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCriterion Gets the specified criteria.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodRemoveCriteron Removes an existing criterion.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also