FamilyPlacementType Enumeration

FamilyPlacementType Enumeration

The type of placement required for a given family.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum FamilyPlacementType
Public Enumeration FamilyPlacementType
public enum class FamilyPlacementType
type FamilyPlacementType
Members
Member nameValueDescription
Adaptive8 The family is an adaptive family.
CurveBased5 The family is based on a line and placed on a work plane.
CurveBasedDetail6 The family is based on a line and place on a specific view (e.g. a detail component).
CurveDrivenStructural7 The family is a structural curve driven member (beam, brace, or slanted column)
Invalid9 This signals an invalid value for the enum.
OneLevelBased0 The family is placed referencing a single level.
OneLevelBasedHosted1 The family is placed referencing a single level and host.
TwoLevelsBased2 The family is placed referencing two levels (e.g. a column).
ViewBased3 The family is view-specific (e.g. a detail annotation)
WorkPlaneBased4 The family is placed on a work plane or face.
See Also