CurveUV Class

CurveUV Class

A class that encapsulates the notion of a curve in the 2D parameter space of a surface in 3D space.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBCurveUV

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CurveUV : IDisposable
Public Class CurveUV
	Implements IDisposable
public ref class CurveUV : IDisposable
type CurveUV = 
    class
        interface IDisposable
    end

The CurveUV type exposes the following members.

Properties
 NameDescription
Public propertyIsBound Describes whether the parameter of the curve is restricted to a particular interval.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodAs3DCurveInXYPlane Returns a 3D curve lying in the XY plane in XYZ coordinates, representing the 2D curve with its UV coordinates identified with XY coordinates.
Public methodComputeDerivatives Computes the first derivative, the second derivative and the unit tangent vector at the specified parameter along the curve.
Public methodStatic memberCreate Create a CurveUV from a bounded 3D Curve lying in the XY plane.
Public methodDisposeReleases all resources used by the CurveUV
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluate Evaluates and returns the point at the specified parameter along the curve.
Public methodGetEndParameter Gets the raw parameter value at the start or end of this curve.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Public methodTransform Transform this CurveUV by the given 2D affine transform if possible.
Top
Remarks
Revit does not have a class to represent 2D curves explicitly.
See Also