Revit 2025.3 API
Compound |
Sets the deck embedding type to use for the specified structural deck.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetDeckEmbeddingType( int layerIdx, StructDeckEmbeddingType embedType )
Public Sub SetDeckEmbeddingType ( layerIdx As Integer, embedType As StructDeckEmbeddingType )
public: void SetDeckEmbeddingType( int layerIdx, StructDeckEmbeddingType embedType )
member SetDeckEmbeddingType : layerIdx : int * embedType : StructDeckEmbeddingType -> unit
Parameters
- layerIdx Int32
- Index of a layer in the CompoundStructure.
- embedType StructDeckEmbeddingType
- The embedding type to be used by the specified layer if it is a structural deck.

Exception | Condition |
---|---|
ArgumentException | The layer is not a structural deck. |
ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration |
See Also